Netty开发环境配置

2019-04-20 15:34|来源: 网路

本章中介绍的Netty开发环境的安装及配置; 这个一系列教程示例的Netty最低要求只有两个:最新版本的Netty 4.xJDK 1.6及更高版本。 最新版本的Netty在项目下载页面中可找到:http://netty.io/downloads.html 。要下载正确的JDK版本,请从Java官方网站下载最新版本的JDK(1.8)。

在阅读时,您可能会对本章中介绍的类有更多的问题。 如果想了解更多关于它们的信息,请参阅API参考。 为了方便起见,本文档中的所有类名都链接到在线API参考。 此外,还可以与Netty项目社区联系,如果有任何不正确的信息,语法错误和错字要让他们知道,以改进文档。


下载Netty

Netty在Apache License v2.0下发布。有关详细信息,请参阅随附的NOTICE.txt,请从以下合适的版本下载,这里我下载的是:netty-4.1.8.Final.tar.bz2

依赖

请注意,Netty没有强制的外部依赖关系。JDK 1.5(对于Netty 4+为 JDK 1.6)或以上是运行Netty所需要的。


从Maven中央存储库下载

将以下依赖项部分添加到pom.xml中:

<dependencies>
  ...
  <dependency>
    <groupId>io.netty</groupId>
    <artifactId>netty</artifactId> <!-- Use 'netty-all' for 4.0 or above -->
    <version>X.Y.Z.Q</version>
    <scope>compile</scope>
  </dependency>
  ...
</dependencies>



在本示例中,将下载的 netty-4.1.8.Final.tar.bz2 解压缩到 F:\worksp\netty\netty-libs 目录下,如下图所示:

blob.png


相关问答

更多

如何配置jave的开发环境

详细步骤如下:    安装JDK      从 http://Java.sun.com/下载jdk-1_5_0_04-windows-i586-p.exe      安装到指定路径,我选择D:\jdk1.5.0      配置环境变量:      Java_HOME: D:\jdk1.5.0   PATH: D:\jdk1.5.0\bin;   CLASSPATH: .;D:\jdk1.5.0\lib\tools.jar;   D:\jdk1.5.0\jre\lib\rt.jar;   安装Ecl ...

如何配置mybatis开发环境

1、打开MyEclipse或者Eclipse,新建一个JavaProject项目mybatis 2、下载所需jar包,右键点击项目依次选择New--Folder,此时弹出对话框,Folder name填写lib。复制jar包粘贴到lib文件夹,展开lib文件夹,选中2个jar包,右键点击jar包,依次选择Build Path--Add to Path。 3、打开SQL Server 2008查询分析器,创建mybatis数据库 create database mybatis 选择mybatis数据 ...

如何配置go语言开发环境

1、下载go的zip文件。并且一定要把文件解压到c:\go目录下。 2、配置windows的高级环境变量。包括:GOROOT、GOOS、GOBIN、GOARCH。并且在path变量里面把c:\go\bin加入。以便可以在命令行直接运行go命令。 举例:我的机器: GOPATH= c:\go;c:\go\src;F:\workspace\goSample01; GOBIN=c:\go\bin;F:\workspace\goSample01\bin; 其中,c:\go是go的安装路径; F:\work ...

netty如何使用

和spring , 先写一个类,然后与一般的bean同样配置 <!-- netty config example --> <bean id="tcpServer" class="com.yixun.collector.server.NettyTCPServer" init-method="createServerBootstrap" destroy-method="stopServer"> <property name="handshakePipelineFactory" ref="handsha ...

如何配置方便阅读和记录注释Netty源码文件的IDEA环境

一、找到文件和代码的模板设置 Preferences->Editor->File and Code Templates,然后在Templates这个tab下,选择你需要修改的文件类型的头模板。 二、修改注释 选中上一步的某一个类型以后,将#parse("File Header.java")这一行删除。

maven开发需要配置什么环境

下载好maven文件,并进行解压缩提取文件。 配置好maven的环境变量。 找到maven目录下的setting.xml文件。(我的路径:D:\Program Files\apache-maven-3.3.3\conf) 打开setting.xml后,找到 标签,内容改为防止jar包的路径。 打开eclipse,在user setting 中选中maven路径下的setting文件,保存。 更新项目,local Repository会根据上步中设置的localRepository自动更新。 至此, ...

hadoop开发环境配置

我的eclipse是装在WINDOWS下的,HADOOP在CENTOS生产环境。 但原理是一样额 http://club.sm160.com/showtopic-937269.aspx HADOOP 版本是hadoop1.0.0(和你的hadoop1.0.4配置相同)

android开发环境配置怎么做?

windows :1.JDK,需要配置环境变量 2.eclipse 解压即可使用 3.Android SDK :解压后运行更新,比较慢 4.ADT,下载或网络安装皆可(在eclipse里的help--》install new software里) linux :1.JDK,需要配置环境变量(修改etc下的profile文件) 2.eclipse rcp版(由于某些外网无法登录,linux下标准的eclipse会缺少某些插件,所以下一个插件较多的版本就ok了) 解压即可使用 3.Android SD ...

android开发环境配置

直接import&nbsp你没描述清楚这个错误是什么意思://f.hiphotos.baidu.com/zhidao/pic/item/203fb80e7bec54e7331d540cb9389b504fc26a2a,你在论坛发的问题里描述的控制台信息也没什么用! 建议你先干两件事: 1,有问题说明环境还没配好,看看是不是ok,你重新解压一下sdk,再不行那就是你下的版本有问题.jpg" target="_blank" title="点击查看大图" class="ikqb_img_alink">补 ...

如何配置android开发环境

您好,配置安卓开发环境有以下几步。 安装JDK。 配置Windows上JDK的变量环境。 下载安装Eclipse。 下载安装Android SDK。 为Eclipse安装ADT插件。